Please be informed that the transaction process is back to normal since 10/07/2026 10:51 UTC.
Posted Jul 10, 2026 - 14:37 UTC
Monitoring
Transaction processing has returned to normal. We are continuing to monitor the platform closely to ensure stability and will provide further updates if required.
Posted Jul 10, 2026 - 12:17 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 10, 2026 - 11:48 UTC
Identified
The PXP Support team has identified an issue affecting intermittent card payment authorizations, which have been failing due to a communication error since 10/07/2026 10:11:04 UTC. Our technical team is actively working with the provider to investigate and resolve the issue. Further updates will be provided as more information becomes available.
For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.