Incident 1243850 - Service Disruption for Card Payments through Adumo

Incident Report for PXP

Resolved

Payments are processing normally from 3/21/2026 15:11 UTC. However, we are awaiting a response from the provider's end. PXP Tech Team will continue to monitor the transactions for stability. PXP systems are operating normally.
Posted Mar 21, 2026 - 16:04 UTC

Identified

We are currently investigating a service disruption affecting Card Payments through Adumo are failing in Authorise errors. We are checking on it with provide and will update you accordingly.
Start Time 14:50 UTC

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Mar 21, 2026 - 15:34 UTC
This incident affected: Transaction Processing.