Exchange rate service outage

Incident Report for PXP

Resolved

The issue has been resolved.
Posted Jun 10, 2026 - 12:58 UTC

Monitoring

Incident Reference:
1272291
Incident Description:
Exchange rate service outage
Impact:
Temporarily causing transaction outages
Start Time
9:50 UTC

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Jun 10, 2026 - 09:45 UTC
This incident affected: Transaction Processing.