Multiple Payment methods down #1255381

Incident Report for PXP

Resolved

There were some issues with notification processing that have now been resolved.
Posted May 01, 2026 - 01:17 UTC

Investigating

We have observed a decline in the success rates for several payment methods. We are currently conducting an internal investigation and will provide you with an update in due course.
Posted Apr 30, 2026 - 23:59 UTC
This incident affected: Transaction Processing.