Incident 1148934- DirectEbankingDeposit/Payment Network

Incident Report for PXP

Resolved

The issue affecting DirectEBankingDeposit/PaymentNetwork has been resolved and services are now operating normally since 7/14/2025 9:36:48 AM. Thank you for your patience while we worked to restore full functionality.
Posted Jul 14, 2025 - 10:31 UTC

Update

We are continuing to investigate this issue.
Posted Jul 14, 2025 - 09:42 UTC

Investigating

We are currently investigating a service disruption affecting DirectEbankingDeposit/Payment Network. Our teams are working to identify the root cause and will provide an update as soon as we have more information.

Start Time 8:00 AM UTC

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Jul 14, 2025 - 09:32 UTC