The issue affecting Interac eTransfer Deposit has been resolved and services are now operating normally. Thank you for your patience while we worked to restore full functionality.
Posted May 02, 2025 - 23:49 UTC
Monitoring
We are currently awaiting confirmation from the provider and will provide updates as they become available.
Posted May 02, 2025 - 23:17 UTC
Identified
Incident Reference:
1118127
Payment Provider:
Payper
Payment Method:
Interac eTransfer Deposit
Incident Description:
The PXP Support team noticed that all transactions in PendingOnCustomer state since 22:18 UTC. PXP technical team is coordinating with the Provider for resolution. PXP systems are operating normally. It is confimed that there was a technical issue at Provider end.
Start Time
02/05/2025 22:18 UTC.
For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.