High Decline Rates for Transactions on BIN 520589

Incident Report for PXP

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 09:29 UTC

Identified

The majority of transactions for BIN '520589' are declining with the response of 'TX NOT PERMITTED', We are aware of this situation and are currently investigating with the Acquirer. As soon as we have more information we will share this with you.
Posted Nov 22, 2025 - 15:55 UTC
This incident affected: Transaction Processing.