Incident 1201514 - Service Disruption for BankTransferRedirectDeposit

Incident Report for PXP

Resolved

The issue affecting BankTransferRedirectDeposit Deposits has been resolved and services are now operating normally since 11/9/2025 11:56:47 AM UTC. Thank you for your patience.
Posted Nov 09, 2025 - 12:27 UTC

Investigating

We are currently investigating a service disruption affecting BankTransferRedirectDeposit. Our teams are working with the provider to identify the root cause and will provide an update as soon as we have more information.
Start Time 04:13

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Nov 09, 2025 - 05:37 UTC
This incident affected: Transaction Processing.