Incident 1178889 - Service Disruption for TrustlyInstantBankDeposit

Incident Report for PXP

Resolved

The issue affecting TrustlyInstantBankDeposit has been resolved and services are now operating normally. Thank you for your patience.

End Time 06:15 AM UTC

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Sep 18, 2025 - 07:04 UTC

Monitoring

The issue has subsided since 06:15 AM UTC and we are monitoring the situation to ensure stability. We will provide a final update once we confirm the issue is fully resolved.

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Sep 18, 2025 - 06:51 UTC

Investigating

We are currently investigating a service disruption affecting TrustlyInstantBankDeposit. Our teams are working with the Provider to identify the root cause and will provide an update as soon as we have more information.
Start Time 05:21 AM UTC

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Sep 18, 2025 - 06:09 UTC
This incident affected: Transaction Processing.