Incident-1187172 - Service Disruption Payment Service

Incident Report for PXP

Resolved

Please note that PSA experienced a temporary outage between 23:05 and 23:28 UTC on 10/06/2025. Although PXP’s internal systems remained fully operational, there were connectivity disruptions caused by the Internet Service Provider. This is to confirm that the issue has now been resolved.
Posted Oct 07, 2025 - 00:30 UTC

Investigating

We are currently investigating a potential service disruption affecting Payment Service. Our teams are working to identify the root cause and will provide an update as soon as we have more information.

Start Time 23:05 UTC

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Oct 06, 2025 - 23:40 UTC
This incident affected: Transaction Processing.