ANYpay Global Blue Settlement Delay - 30/12/2024
Incident Report for PXP
Resolved
This incident has been resolved.
Posted Jan 08, 2025 - 09:07 UTC
Identified
Incident Reference:
1065513
Acquirer
Global Blue
Incident Description:
There is a settlement delay for Global Blue transactions dated 29/12/2024, due to a submission failure.
Impact:
Settlement delay for transactions taken on 29th December 2024.

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxpfinancial.com or click here to create a ticket.
Posted Jan 02, 2025 - 09:24 UTC
This incident affected: ANYpay (Settlement).