The approval rate is back to normal since 10/21/2025 5:50 AM UTC. PXP Tech Team will continue to monitor the transactions for stability. PXP systems are operating normally.
Posted Oct 21, 2025 - 15:53 UTC
Update
We have received a notification from VISA stating that there is an issue with their issuing client in USA. VISA is in touch with their client and are working with them to resolve the issue.
For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Oct 21, 2025 - 06:33 UTC
Investigating
We are currently investigating a service disruption affecting VISA Deposit especially for US labels. Our teams are working to identify the root cause and will provide an update as soon as we have more information. Start Time ~ 10/21/2025 4:04 AM UTC
For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.