ANYpay Fexco Settlement Delay - 10/03/2025

Incident Report for PXP

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 09:40 UTC

Identified

Incident Reference:
1095018
Acquirer
Fexco
Incident Description:
There may be a settlement delay for Fexco transactions dated 09/03/2025, due to a transaction failure in the submission.
Impact:
Possible 24 hour settlement delay for transactions taken on 9th March 2025.

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Mar 10, 2025 - 12:18 UTC