Incident 1102980 - Service Disruption for Phone Calls

Incident Report for PXP

Resolved

The issue affecting our telecommunications has been resolved and services are now operating normally. Thank you for your patience while we worked to restore full functionality.

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Mar 28, 2025 - 10:13 UTC

Monitoring

A fix has been implemented and we are monitoring the situation to ensure stability. We will provide a final update once we confirm the issue is fully resolved.

For further information please contact us by email at support@pxp.io or click here to create a ticket.
Posted Mar 28, 2025 - 10:03 UTC

Identified

Our Telecoms provider has identified the cause of the issue affecting our Telecommunications and are working to resolve this. We will share further updates shortly.

For further information please contact us by email at support@pxp.io or click here to create a ticket.
Posted Mar 28, 2025 - 09:26 UTC

Investigating

We are currently investigating a service disruption affecting our telecommunications. Our teams are working to identify the root cause and will provide an update as soon as we have more information.

For further information please contact us by email at support@pxp.io or click here to create a ticket.
Posted Mar 28, 2025 - 09:13 UTC
This incident affected: Help Centre.