Incident 1307191 - Service Disruption for ECMC and VISA Deposit

Incident Report for PXP

Resolved

The issue affecting ECMC and VISA deposits has been resolved and services are now operating normally. Thank you for your patience while we worked to restore full functionality.

End Time 12:54 PM

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Sep 02, 2026 - 13:33 UTC

Investigating

We are currently investigating a service disruption affecting ECMC and VISA Deposits. Our teams are working to identify the root cause and will provide an update as soon as we have more information.
Start Time 07:30 AM

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Sep 02, 2026 - 12:22 UTC
This incident affected: Transaction Processing.