Incident 1131627 - Service Disruption for multiple payment methods

Incident Report for PXP

Resolved

The issue affecting multiple payment methods has been resolved and services are now operating normally. There were Network glitches at Partner's end during the impacted timeframes.

End Time 02:48 AM UTC

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Jun 03, 2025 - 03:56 UTC

Update

We have observed payment failures for multiple payment methods again between 2:42 AM to 02:48 AM UTC. We are investigating on this internally. Updates will be provided as we receive more information.
Posted Jun 03, 2025 - 03:30 UTC

Monitoring

Payment processing has been back to normal since 02:04 AM UTC. Payments failed in 2 durations, first was between 01:26 AM UTC to 01:32 AM UTC and second was between 01:58 AM UTC to 02:04 AM UTC. Our teams are investigating on the cause. We will provide more updates on the issue as more information becomes available.

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Jun 03, 2025 - 02:45 UTC

Investigating

We are currently investigating a service disruption affecting multiple payment methods. Our teams are working to identify the root cause and will provide an update as soon as we have more information.
Start Time 01:26 AM UTC

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Jun 03, 2025 - 02:42 UTC
This incident affected: Transaction Processing.