Incident - Service Disruption for Multiple payment methods

Incident Report for PXP

Resolved

The issue affecting multiple payment methods has been resolved and services are now operating normally. Thank you for your patience while we worked to restore full functionality.

End Time 05:45 AM UTC

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted May 06, 2025 - 06:22 UTC

Investigating

We are currently investigating a service disruption affecting multiple payment methods. Our teams are working to identify the root cause and will provide an update as soon as we have more information.
Start Time 05:10 AM UTC

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted May 06, 2025 - 06:21 UTC
This incident affected: Transaction Processing.