Incident 1241945 - Service Disruption for IdealDeposit

Incident Report for PXP

Resolved

There was a change done at Provider's end without prior notification to PXP. Upon receiving the details about the change, our development team has made a change at 17:00 UTC which has resolved the issue. The approval rate is back to normal since 17:00 UTC. PXP Tech Team will continue to monitor the transactions for stability. PXP systems are operating normally.
Posted Mar 16, 2026 - 17:29 UTC

Identified

The issue has been identified and the teams are actively working to determine the most effective solution. Updates will be provided as more information becomes available.
Posted Mar 16, 2026 - 16:16 UTC

Investigating

We are currently investigating a service disruption affecting IdealDeposit. Our teams are working to identify the root cause and will provide an update as soon as we have more information.
Start Time 10:01

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Mar 16, 2026 - 13:22 UTC
This incident affected: Transaction Processing.