Incident 1198672 - Service Disruption for Interac eTransfer Deposits

Incident Report for PXP

Resolved

The issue affecting Interac eTransfer Deposits has been resolved and services are now operating normally. Proivder has confirmed that during the timeframe, Royal Bank of Canada (RBC), one of Canada’s major banks, was undergoing scheduled maintenance.

End Time 8:22 AM

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Nov 02, 2025 - 09:20 UTC

Monitoring

We are monitoring the situation to ensure stability. We will provide a final update once we confirm the issue is fully resolved.
Posted Nov 02, 2025 - 08:54 UTC

Investigating

We are currently investigating a service disruption affecting Interac eTransfer Deposits. Our teams are working to identify the root cause and will provide an update as soon as we have more information.
Start Time ***07:41***

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Nov 02, 2025 - 08:28 UTC
This incident affected: Transaction Processing.