The issue affecting Interac eTransfer Deposits and Interac Withdrawals has been resolved and services are now operating normally. Thank you for your patience.
End Time 04:09 AM UTC
For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Nov 08, 2025 - 05:08 UTC
Monitoring
Provider has confirmed that they were having delays with their Interac Network. We see that the conversion rates are back to normal since 11/8/2025 4:09 AM UTC. We will provide a final update once we confirm the issue is fully resolved.
For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Nov 08, 2025 - 04:41 UTC
Investigating
We are currently investigating a service disruption affecting Interac eTransfer Deposit and Interac Withdrawals. Our teams are working with the provider to identify the root cause and will provide an update as soon as we have more information. Start Time 12:50 AM UTC
For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.