The issue affecting Mastercard 3-D Secure (ECMC 3DS) authentication has been resolved. Services have returned to normal operation at 08:52 UTC, and transaction processing is functioning as expected. We will continue to monitor the platform to ensure ongoing stability.
Posted Jul 15, 2026 - 09:10 UTC
Monitoring
We see an improvement in the 3DS authentication. We are monitoring the issue
Posted Jul 15, 2026 - 08:25 UTC
Investigating
We are currently investigating a service disruption affecting Mastercard 3-D Secure (ECMC 3DS) authentication. The issue was detected at 06:59 UTC and is impacting Mastercard 3-D Secure authentication services. We are actively monitoring the situation and will provide further updates as more information becomes available.
For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.