The Worldpay team has identified an error introduced by a recent change and is currently working to revert to the previous configuration to restore service. The estimated time for resolution is 20:45 UTC (15:45 EST). We will provide an update as soon as additional information becomes available.
Posted Mar 21, 2026 - 18:09 UTC
Identified
An issue has been identified with WorldPay which is impacting transaction authorizations. Their support teams are working to resolve the issue and restore services. We will provide an update as soon as additional information becomes available.
Posted Mar 21, 2026 - 17:00 UTC
Investigating
We have observed that card payments processed through the provider Worldpay have been declining since 3/21/2026 at 6:45:00 AM UTC. Our teams are currently investigating the root cause of this issue and will provide an update as soon as additional information becomes available. Start Time ***06:45***
For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.