The issue affecting PayPal has been resolved and services are now operating normally.
End Time 12:11 AM UTC
For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Nov 18, 2025 - 13:01 UTC
Monitoring
We continue to notice the approval rates have improved since 12:11 AM UTC. PXP Systems are operating normally. Updates will be provided as more information becomes available.
For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Nov 18, 2025 - 12:28 UTC
Identified
We are observing transactions through PayPal failing in communication errors since 11:32 AM UTC. PayPal has confirmed that they are experiencing a system issue that may be impacting REST APIs, Braintree, Venmo in the Production Environment. Updates will be shared as more information becomes available.
For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.