Incident 1251616 - Service Disruption for Interac Deposits and Withdrawals

Incident Report for PXP

Resolved

Provider confirmed there were service delays associated with the Interac maintenance have now stabilized. The approval rate is back to normal since 09:15 AM UTC. PXP Tech Team will continue to monitor the transactions for stability. PXP systems are operating normally.
Posted Apr 19, 2026 - 09:36 UTC

Investigating

We are currently investigating a service disruption affecting Interac Deposits and Withdrawals. Our teams are working with the provider to identify the root cause and will provide an update as soon as we have more information.
Start Time 08:05

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Apr 19, 2026 - 09:29 UTC
This incident affected: Transaction Processing.