Incident 1299357 - Service Disruption for Paysafecard deposit

Incident Report for PXP

Identified

Provider has confirmed that currently undergoing maintenance on their end. Updates will be provided as more information becomes available.
Posted Aug 11, 2026 - 07:16 UTC

Investigating

We are currently investigating a service disruption affecting Paysafecard deposit/ Paysafecard. Our teams are checking with the provider on the root cause and will provide an update as soon as we have more information.
Start Time ***06:00***

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Aug 11, 2026 - 06:53 UTC
This incident affects: Transaction Processing.