Incident 1298759 - Service Disruption for Payper/Interac eTransfer.

Incident Report for PXP

Resolved

Provider mentioned in their status page that the maintenance has been completed at 10 AM UTC. We observe an improvement in success rate as well.
Posted Aug 09, 2026 - 10:38 UTC

Monitoring

Interac eTransfer transactions are hung in Pendingoncustomer state starting at 03:42 AM UTC. The disruption originated from the payment service provider's end, as confirmed by their status page. We are currently monitoring the status.

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Aug 09, 2026 - 07:49 UTC
This incident affected: Transaction Processing.