Incident 1206630 - Service Disruption for Interac eTransferDeposit

Incident Report for PXP

Resolved

The previously reported issue impacting Interac eTransfer Deposit has been fully resolved. All services have returned to normal operation following the completion of maintenance, and transactions have been processing as expected since 11/23/2025 at 10:30 AM UTC.
Posted Nov 23, 2025 - 12:31 UTC

Identified

We have received a notification from the provider saying that Interac is affected due to a scheduled maintenance. We will provide an update as more information becomes available.

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Nov 23, 2025 - 10:07 UTC

Investigating

We are currently investigating a service disruption affecting Interac eTransferDeposit. We are working with the provider to identify the root cause and will provide an update as soon as we have more information.
Start Time 07:02 AM UTC

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxp.io or click here to create a ticket.
Posted Nov 23, 2025 - 08:04 UTC
This incident affected: Transaction Processing.